ISO MP10 Wetside

Users who are viewing this thread

jerad.david

Emerald Crab
Joined
Dec 7, 2007
Messages
112
Location
Thibodaux, Louisiana
Setting the office tank back up and I noticed my MP10 wetside magnet ruptured and rusted. Anyone have one they are willing to part with before I order a new one?
 

V3NOMUS

Neon Goby
Joined
Jan 12, 2014
Messages
771
Location
Prairieville, LA
Setting the office tank back up and I noticed my MP10 wetside magnet ruptured and rusted. Anyone have one they are willing to part with before I order a new one?
I'm going through the same thing with both my mp40 wetsides. Magnets broke and are rusting. I contacted ecotech to buy just the magnet and was offered to pay shipping both ways and send my wetsides to them and they will fix the problem and send them back. So cost me $50 to ship/return ship both wetsides instead of $200 for 2 new ones. Might be worth contacting them to see. Mine are over 8 years old and they still covering that under warranty.
 

V3NOMUS

Neon Goby
Joined
Jan 12, 2014
Messages
771
Location
Prairieville, LA
Got my confirmation today about them receiving my powerheads. Did you end up getting ahold of them?
 

Attachments

  • Screenshot_20220117-142615_Gmail.jpg
    Screenshot_20220117-142615_Gmail.jpg
    74 KB · Views: 11

V3NOMUS

Neon Goby
Joined
Jan 12, 2014
Messages
771
Location
Prairieville, LA
Sweet! I just updated my post a little while ago. Instead of them just replacing the magnets, they ended up just sending me 2 brand new wet sides. Hope you have the same luck!
 
Top